» Ubuntu » Packages » lucid (10.04LTS) » libs » libfbembed2.1
lucid  ] [  precise  ]
[ Source: firebird2.1  ]

Package: libfbembed2.1 (2.1.3.18185-0.ds1-6build1) [universe]

Links for libfbembed2.1

Screenshot

Ubuntu Resources:

Download Source Package firebird2.1:

Maintainer:

Please consider filing a bug or asking a question via Launchpad before contacting the maintainer directly.

Original Maintainers (usually from Debian):

  • Debian Firebird Group (Mail Archive)
  • Daniel Urban
  • Damyan Ivanov
  • Francesco Paolo Lovergine

It should generally not be necessary for users to contact the original maintainer.

External Resources:

Similar packages:

Firebird embedded client/server library

Firebird is a relational database offering many ANSI SQL-99 features that runs on Linux, Windows, and a variety of Unix platforms. Firebird offers excellent concurrency, high performance, and powerful language support for stored procedures and triggers. It has been used on production systems under a variety of names since 1981.

This package contains libfbembed - the embedded client/server library for Firebird.

It can work with remote Firebird servers (either super-server or classic) via TCP connections, in the same way libfbclient does.

Contrary to libfbclient, libfbembed is not thread-safe.

When working with local database libfbembed works directly with the database file without the need of a separate server process. It needs a separate lock manager -- fb_lock_mgr -- which is in firebird2.1-classic package.

If you are in doubt, you most probably need libfbclient2, instead of this package.

Other Packages Related to libfbembed2.1

  • depends
  • recommends
  • suggests
  • enhances
  • dep: firebird2.1-common (= 2.1.3.18185-0.ds1-6build1)
    common files for firebird 2.1 servers and clients
  • dep: firebird2.1-common-doc (= 2.1.3.18185-0.ds1-6build1)
    copyright, licensing and changelogs of firebird2.1
  • dep: firebird2.1-server-common (= 2.1.3.18185-0.ds1-6build1)
    common files for firebird 2.1 servers
  • dep: libc6 (>= 2.7)
    Embedded GNU C Library: Shared libraries
    also a virtual package provided by libc6-udeb
  • dep: libgcc1 (>= 1:4.1.1)
    GCC support library
  • dep: libicu42 (>= 4.2-1)
    International Components for Unicode
  • dep: libstdc++6 (>= 4.1.1)
    The GNU Standard C++ Library v3

Download libfbembed2.1

Download for all available architectures
Architecture Package Size Installed Size Files
amd64 1,331.8 kB3,452.0 kB [list of files]
i386 1,375.5 kB3,532.0 kB [list of files]