» Ubuntu » Packages » lucid (10.04LTS) » libs » libgsm1
lucid  ] [  precise  ] [  trusty  ] [  utopic  ] [  vivid  ]
[ Source: libgsm  ]

Package: libgsm1 (1.0.13-3)

Links for libgsm1

Screenshot

Ubuntu Resources:

Download Source Package libgsm:

Maintainer:

Please consider filing a bug or asking a question via Launchpad before contacting the maintainer directly.

Original Maintainer (usually from Debian):

  • Jochen Friedrich

It should generally not be necessary for users to contact the original maintainer.

Similar packages:

Shared libraries for GSM speech compressor

This package contains runtime shared libraries for libgsm, an implementation of the European GSM 06.10 provisional standard for full-rate speech transcoding, prI-ETS 300 036, which uses RPE/LTP (residual pulse excitation/long term prediction) coding at 13 kbit/s.

GSM 06.10 compresses frames of 160 13-bit samples (8 kHz sampling rate, i.e. a frame rate of 50 Hz) into 260 bits; for compatibility with typical UNIX applications, our implementation turns frames of 160 16-bit linear samples into 33-byte frames (1650 Bytes/s). The quality of the algorithm is good enough for reliable speaker recognition; even music often survives transcoding in recognizable form (given the bandwidth limitations of 8 kHz sampling rate).

The interfaces offered are a front end modelled after compress(1), and a library API. Compression and decompression run faster than realtime on most SPARCstations. The implementation has been verified against the ETSI standard test patterns.

Other Packages Related to libgsm1

  • depends
  • recommends
  • suggests
  • enhances
  • dep: libc6 (>= 2.3.4)
    Embedded GNU C Library: Shared libraries
    also a virtual package provided by libc6-udeb

Download libgsm1

Download for all available architectures
Architecture Package Size Installed Size Files
amd64 28.6 kB120.0 kB [list of files]
i386 26.9 kB116.0 kB [list of files]