» Ubuntu » Packages » lucid (10.04LTS) » interpreters » liblua5.1-wsapi1
lucid  ] [  precise  ]
[ Source: lua-wsapi  ]

Package: liblua5.1-wsapi1 (1.1.0-6) [universe]

Links for liblua5.1-wsapi1

Screenshot

Ubuntu Resources:

Download Source Package lua-wsapi:

Maintainer:

Please consider filing a bug or asking a question via Launchpad before contacting the maintainer directly.

Original Maintainer (usually from Debian):

  • Enrico Tassi

It should generally not be necessary for users to contact the original maintainer.

External Resources:

Similar packages:

Web server API abstraction layer for the Lua language version 5.1

WSAPI is an API that abstracts the web server for Lua web applications, allowing the same application to be used in different web servers.

This package contains the WSAPI utility libraries (for common tasks like url encoding/decoding) as well as the following backends (server implementations):

 - CGI (the regular environment-variables based protocol)
 - xavante (for the Xavante web server)

The fastcgi backends is available in the separate package liblua5.1-wsapi-fcgi.

This package also includes a backward compatible implementation of SAPI, used by old versions of cgilua.

Other Packages Related to liblua5.1-wsapi1

  • depends
  • recommends
  • suggests
  • enhances
  • dep: liblua5.1-filesystem0
    luafilesystem library for the Lua language version 5.1
  • dep: liblua5.1-rings0
    Lua state creation and control library for the Lua language version 5.1
  • dep: lua5.1
    Simple, extensible, embeddable programming language

Download liblua5.1-wsapi1

Download for all available architectures
Architecture Package Size Installed Size Files
all 13.4 kB120.0 kB [list of files]