» Ubuntu » Packages » lucid (10.04LTS) » perl » libscope-upper-perl
lucid  ] [  precise  ] [  raring  ] [  saucy  ] [  trusty  ] [  utopic  ]
[ Source: libscope-upper-perl  ]

Package: libscope-upper-perl (0.10-1) [universe]

Links for libscope-upper-perl

Screenshot

Ubuntu Resources:

Download Source Package libscope-upper-perl:

Maintainer:

Please consider filing a bug or asking a question via Launchpad before contacting the maintainer directly.

Original Maintainers (usually from Debian):

It should generally not be necessary for users to contact the original maintainer.

External Resources:

Similar packages:

module to manipulate upper scopes

Scope::Upper is a Perl module that provides a way for Perl programs to defer actions at run-time until the control flow returns to the upper scope. It currently enables developers to:

 * Hook an upper scope end with "reap"
 * Localize variables, array/hash values or deletions of elements in
   higher contexts with respectively "localize", "localize_elem" and
   "localize_delete"
 * Return values immediately to an upper level with "unwind", and know
   which context was in use then with "want_at"

Other Packages Related to libscope-upper-perl

  • depends
  • recommends
  • suggests
  • enhances
  • dep: libc6 (>= 2.1.3) [i386]
    Embedded GNU C Library: Shared libraries
    also a virtual package provided by libc6-udeb
    dep: libc6 (>= 2.2.5) [amd64]
  • dep: perl (>= 5.10.1-8ubuntu1)
    Larry Wall's Practical Extraction and Report Language
  • dep: perlapi-5.10.1
    virtual package provided by perl-base

Download libscope-upper-perl

Download for all available architectures
Architecture Package Size Installed Size Files
amd64 28.6 kB132.0 kB [list of files]
i386 28.0 kB128.0 kB [list of files]