» Ubuntu » Pakiety » lucid-updates » libs » libsoup-gnome2.4-1
lucid  ] [  lucid-updates  ] [  precise  ] [  raring  ] [  saucy  ] [  saucy-updates  ] [  trusty  ] [  utopic  ]
[ Pakiet źródłowy: libsoup2.4  ]

Pakiet: libsoup-gnome2.4-1 (2.30.2-0ubuntu0.2)

Odnośniki dla libsoup-gnome2.4-1

Screenshot

Zasoby systemu Ubuntu:

Pobieranie pakietu źródłowego libsoup2.4:

Opiekun:

Please consider filing a bug or asking a question via Launchpad before contacting the maintainer directly.

Original Maintainers (usually from Debian):

It should generally not be necessary for users to contact the original maintainer.

Podobne pakiety:

an HTTP library implementation in C -- GNOME support library

It was originally part of a SOAP (Simple Object Access Protocol) implementation called Soup, but the SOAP and non-SOAP parts have now been split into separate packages.

libsoup uses the Glib main loop and is designed to work well with GTK+ applications. This enables GNOME applications to access HTTP servers on the network in a completely asynchronous fashion, very similar to the GTK+ programming model (a synchronous operation mode is also supported for those who want it).

The GNOME support library is used for features which are important to GNOME apps, but which require GNOME-specific libraries that non-GNOME apps may not want to add dependencies on.

Features:

 * Both asynchronous (GMainLoop and callback-based) and synchronous APIs
 * Automatically caches connections
 * SSL Support using GnuTLS
 * Proxy support, including authentication and SSL tunneling
 * Client support for Digest, NTLM, and Basic authentication
 * Server support for Digest and Basic authentication
 * Basic client-side SOAP and XML-RPC support

This package contains the GNOME support shared library.

Inne pakiety związane z libsoup-gnome2.4-1

  • wymaga
  • poleca
  • sugeruje
  • dep: libc6 (>= 2.2.5) [amd64]
    Embedded GNU C Library: Shared libraries
    również pakiet wirtualny udostępniany przez libc6-udeb
    dep: libc6 (>= 2.3.6-6~) [i386]
  • dep: libgconf2-4 (>= 2.27.0)
    GNOME configuration database system (shared libraries)
  • dep: libgcrypt11 (>= 1.4.2)
    LGPL Crypto library - runtime library
  • dep: libglib2.0-0 (>= 2.21.3)
    The GLib library of C routines
  • dep: libgnome-keyring0 (>= 2.20.3)
    GNOME keyring services library
  • dep: libgnutls26 (>= 2.7.14-0)
    the GNU TLS library - runtime library
  • dep: libproxy0 (>= 0.2.3)
    automatic proxy configuration management library (shared)
  • dep: libsoup2.4-1 (>= 2.28.0)
    an HTTP library implementation in C -- Shared library
  • dep: libsqlite3-0 (>= 3.6.22)
    SQLite 3 shared library
  • dep: libxml2 (>= 2.6.27)
    GNOME XML library
  • dep: zlib1g (>= 1:1.1.4)
    compression library - runtime

Pobieranie libsoup-gnome2.4-1

Pobierz dla wszystkich dostępnych architektur
Architektura Rozmiar pakietu Rozmiar po instalacji Pliki
amd64 12,8 KiB112,0 KiB [lista plików]
i386 11,6 KiB108,0 KiB [lista plików]