» Ubuntu » Packages » disco » libdevel » libdpdk-dev
xenial  ] [  xenial-updates  ] [  bionic  ] [  bionic-updates  ] [  cosmic  ] [  disco  ]
[ Source: dpdk  ]

Package: libdpdk-dev (17.11.4-1)

Links for libdpdk-dev

Screenshot

Ubuntu Resources:

Download Source Package dpdk:

Maintainer:

Please consider filing a bug or asking a question via Launchpad before contacting the maintainer directly.

Original Maintainers (usually from Debian):

  • Debian DPDK Maintainers (Mail Archive)
  • Luca Boccassi
  • Christian Ehrhardt
  • Santiago Ruano Rincón

It should generally not be necessary for users to contact the original maintainer.

External Resources:

Similar packages:

Data Plane Development Kit (basic development files)

Other Packages Related to libdpdk-dev

  • depends
  • recommends
  • suggests
  • enhances
  • dep: libpcap-dev
    development library for libpcap (transitional package)
  • dep: librte-acl17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-acl runtime library)
  • dep: librte-bitratestats17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_bitratestats runtime library)
  • dep: librte-bus-pci17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_bus_pci runtime library)
  • dep: librte-bus-vdev17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_bus_dev runtime library)
  • dep: librte-cfgfile17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-cfgfile runtime library)
  • dep: librte-cmdline17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-cmdline runtime library)
  • dep: librte-cryptodev17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-cryptodev runtime library)
  • dep: librte-distributor17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-distributor runtime library)
  • dep: librte-eal17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-eal runtime library)
  • dep: librte-efd17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_efd runtime library)
  • dep: librte-ethdev17.11 (= 17.11.4-1)
    Data Plane Development Kit (libethdev runtime library)
  • dep: librte-eventdev17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_eventdev runtime library)
  • dep: librte-flow-classify17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-flow-classify runtime library)
  • dep: librte-gro17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-gro runtime library)
  • dep: librte-gso17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-gso runtime library)
  • dep: librte-hash17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-hash runtime library)
  • dep: librte-ip-frag17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-ip-frag runtime library)
  • dep: librte-jobstats17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-jobstats runtime library)
  • dep: librte-kni17.11 (= 17.11.4-1) [not i386]
    Data Plane Development Kit (librte-kni runtime library)
  • dep: librte-kvargs17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-kvargs runtime library)
  • dep: librte-latencystats17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_latencystats runtime library)
  • dep: librte-lpm17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-lpm runtime library)
  • dep: librte-mbuf17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-mbuf2 runtime library)
  • dep: librte-member17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-member runtime library)
  • dep: librte-mempool-octeontx17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_mempool_octeontx runtime library)
  • dep: librte-mempool-ring17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_mempool_ring runtime library)
  • dep: librte-mempool-stack17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_mempool_stack runtime library)
  • dep: librte-mempool17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-mempool runtime library)
  • dep: librte-meter17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-meter runtime library)
  • dep: librte-metrics17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_metrics runtime library)
  • dep: librte-net17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-net runtime library)
  • dep: librte-pci17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_pci runtime library)
  • dep: librte-pdump17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_pdump runtime library)
  • dep: librte-pipeline17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-pipeline runtime library)
  • dep: librte-pmd-af-packet17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-pmd-af-packet runtime library)
  • dep: librte-pmd-ark17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_pmd_ark runtime library)
  • dep: librte-pmd-avp17.11 (= 17.11.4-1) [amd64]
    Data Plane Development Kit (librte_pmd_avp runtime library)
  • dep: librte-pmd-bnxt17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-pmd-bnxt runtime library)
  • dep: librte-pmd-bond17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-pmd-bond runtime library)
  • dep: librte-pmd-crypto-scheduler17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_pmd_crypto_scheduler runtime library)
  • dep: librte-pmd-cxgbe17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-pmd-cxgbe runtime library)
  • dep: librte-pmd-e1000-17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-pmd-e1000 runtime library)
  • dep: librte-pmd-ena17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-pmd-ena runtime library)
  • dep: librte-pmd-enic17.11 (= 17.11.4-1) [not ppc64el]
    Data Plane Development Kit (librte-pmd-enic runtime library)
  • dep: librte-pmd-failsafe17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-pmd-failsafe runtime library)
  • dep: librte-pmd-fm10k17.11 (= 17.11.4-1) [amd64, i386]
    Data Plane Development Kit (librte-pmd-fm10k runtime library)
  • dep: librte-pmd-i40e17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-pmd-i40e runtime library)
  • dep: librte-pmd-ixgbe17.11 (= 17.11.4-1) [not ppc64el]
    Data Plane Development Kit (librte-pmd-ixgbe runtime library)
  • dep: librte-pmd-kni17.11 (= 17.11.4-1) [not i386]
    Data Plane Development Kit (librte_pmd_kni runtime library)
  • dep: librte-pmd-lio17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_pmd_lio runtime library)
  • dep: librte-pmd-mlx4-17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-pmd-mlx4 runtime library)
  • dep: librte-pmd-mlx5-17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-pmd-mlx5 runtime library)
  • dep: librte-pmd-nfp17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_pmd_nfp runtime library)
  • dep: librte-pmd-null-crypto17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-pmd-null-crypto runtime library)
  • dep: librte-pmd-null17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-pmd-null runtime library)
  • dep: librte-pmd-octeontx-ssovf17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_pmd_octeontx_ssovf runtime library)
  • dep: librte-pmd-octeontx17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_pmd_octeontx runtime library)
  • dep: librte-pmd-pcap17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-pmd-pcap runtime library)
  • dep: librte-pmd-qede17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-pmd-qede runtime library)
  • dep: librte-pmd-ring17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-pmd-ring runtime library)
  • dep: librte-pmd-sfc-efx17.11 (= 17.11.4-1) [amd64]
    Data Plane Development Kit (librte_pmd_sfc_efx runtime library)
  • dep: librte-pmd-skeleton-event17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_pmd_skeleton_event runtime library)
  • dep: librte-pmd-softnic17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-pmd-softnic runtime library)
  • dep: librte-pmd-sw-event17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_pmd_sw_event runtime library)
  • dep: librte-pmd-tap17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_pmd_tap runtime library)
  • dep: librte-pmd-thunderx-nicvf17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_pmd_thunderx_nicvf runtime library)
  • dep: librte-pmd-vhost17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-pmd-vhost runtime library)
  • dep: librte-pmd-virtio17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-pmd-virtio runtime library)
  • dep: librte-pmd-vmxnet3-uio17.11 (= 17.11.4-1) [not ppc64el]
    Data Plane Development Kit (librte-pmd-vmxnet3-uio runtime library)
  • dep: librte-port17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-port runtime library)
  • dep: librte-power17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-power runtime library)
  • dep: librte-reorder17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte-reorder runtime library)
  • dep: librte-ring17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_ring runtime library)
  • dep: librte-sched17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_sched runtime library)
  • dep: librte-security17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_security runtime library)
  • dep: librte-table17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_table runtime library)
  • dep: librte-timer17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_timer runtime library)
  • dep: librte-vhost17.11 (= 17.11.4-1)
    Data Plane Development Kit (librte_vhost runtime library)
  • dep: zlib1g-dev
    compression library - development

Download libdpdk-dev

Download for all available architectures
Architecture Package Size Installed Size Files
amd64 2,048.7 kB10,634.0 kB [list of files]
arm64 1,815.9 kB9,370.0 kB [list of files]
i386 2,152.9 kB9,545.0 kB [list of files]
ppc64el 1,803.3 kB9,670.0 kB [list of files]